Discuss anything related to The Sims 3 in this forum. You can showcase your own items here as well. Or participate in one of our legacies!

The hell that is the Sims 3 Launcher

SNW Webmiss
14293 Posts
Post
I will post here what I also posted on my Facebook page. A lot of people are confused why I am uninstalling everything and then installing it again. I would love to explain it to everyone but it frustrated me to no end that it's such a complicated and insane story. And it most certainly doesn't fit in a tweet whatsoever :p
When I try to install *any* Sims3Pack, it opens the launcher. And it appears under Downloads. But when I click install. It won't install!

So then I think. Okay, I'll try again. But nooooo.

The past few weeks it seemed to work when I opened up the game. Then opened the Launcher from the menu in-game. The launcher would open. I could then click Install on one item. Wouldn't work for multiple items, only one item at a time. And then it would install. But it wouldn't appear right away. So I'd have to close my launcher, and my game. Then restart it again. And then it would appear.

But that was before. Doesn't work anymore

And worst part probably is that I cannot use the launcher when I open the game from within origin. If I do that, I have to login EVERY single time. And on top of that when I click the play button, it closes the launcher. So I made a shortcut that opens the EXE of the game. And that works. But then it does skip the launcher so I have to open it from within the game.

I have to add, I tried emptying my Sims 3 folder. Or rather, just remove it altogether. I tried this several times but that did not help at all. I want to say, I've had this problem ever since I installed my Sims 3 game again, on the new HDD etc. So it's a fresh install. And I had trouble from the moment I had everything installed. So I uninstalled UL and reinstalled again. Seemed to work at that moment but afterwards it didn't work anymore.

I have tried installing my packages with other tools from Delphy for example. Like the multi-installer. But that somehow managed to ruin the patterns I tried to install. I have never seen such a weird thing but all my patterns ended up with the same pattern, but everything had different colour values. Sooooo weird.

My game is fully patched. Although the launcher keeps telling me that the store has a new patch and I keep installing it but yeah, keeps bringing it up.

And all of this ^ is so incredibly annoying!!!!

I have heard a lot of people are experiencing problems with their launcher. So I blame this on bugs in the launcher and not something on my part.

So I think I have to uninstall and reinstall everything again, at least prior to Island Paradise.
I got a lot of help and advice from people on Twitter and Facebook. Thanks everyone for this. I do appreciate it. So far though nothing worked.

I need my launcher to work. Not only for my official bought store stuff, but also for my own CC that I need to test and see in game, and take screens of.

Last night I started to uninstall everything. And once that was done, I rebooted. After that I started installing everything again. I have everything boxed but I used Origin instead since it's quicker installing and saves having 17 (?) boxes on my desk.

So far, in 2013, I've had to uninstall and re-install everything 4 times. Yes, 4 times. Now, 2 times it wasn't because of the launcher, but because of my broken hard disk. But ever since I got my computer back with the replaced hard disk, I've tried to install everything. And the installing works. But the launcher doesn't. So then I uninstalled it last month because even in-game (the downloads dashboard thing) it didn't really work. And when it did, it was SUPER slow and it took forever for one item. I have 1600 pages of items, or something along those lines. :worry:

Now I bought a new set yesterday, and I can't install it!

The uninstall/reinstall yesterday didn't help. My launcher still doesn't work (doesn't install any Sims3Packs and it also won't launch the game).

And that is why I am now with one option left. Manually uninstall everything to make sure there is *NOTHING* left in the registry whatsoever. And then hopefully, maybe, tonight I can have a working launcher again? I hope...

Nooboo
2 Posts
Post
Have you tried Game Help:Data Execution Prevention/TS3Whttp://simswiki.info/wiki.php?title=Game_Help:Data_Execution_Prevention/TS3W. Here is the link:

SNW Webmiss
14293 Posts
Post
I appreciate the advice, but we already managed to solve it by doing the manual uninstall and also by running the launcher and game as administrator. :D We tried compatibility mode as well, but I didn't mention that here anymore cause I got straight back to the game once the problems were solved :D

Nooboo
2 Posts
Post
Glad you got your game working again. Don't know if you had problems with the launcher telling you there is a game update but not allowing the update or reporting the wrong version but you can remove the version.tag file from the game folder and when you launch the game a new version.tag file will be recreated. Been through my own kind of hell with the launcher but nothing like what you described! Good luck going forward.

SNW Webmiss
14293 Posts
Post
Thanks! Yeah the run as administrator option seems to be working wonders so far. I can install store items again, and my own CC as well. So I can continue to create stuff for the website :D

As for the game update, I did have issues with the launcher telling me there is a *store* update. I'd run it and when I reopened the launcher, or just clicked refresh, it would prompt me to update it again. I've heard this is a bug that a lot of people have. So it does in fact install but the notification keeps popping up.


  • Stats
  • Who is online

    In total there is 1 user online :: 0 registered, 0 hidden and 1 guest (based on users active over the past 5 minutes)
    Most users ever online was 97 on Jun 05, 2013 4:06pm

    Users browsing this forum: No registered users and 1 guest

cron